Delay During Capital Applications

Incident Report for Lightspeed - Status Page

Resolved

The incident has been resolved. Payments and Capital onboarding are now fully operational.
Posted Apr 03, 2025 - 14:00 EDT

Investigating

We are currently aware of an issue causing prolonged delays during the Capital application process. Our team is investigating. Please be advised that after timeout, it is still possible to proceed with uploading documents.
Posted Apr 03, 2025 - 11:07 EDT