Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 24, 2025 - 00:00 EDT
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Monday, March 24 at 15:00 AEDT Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEDT.
RESOLVED - Fixed an issue where Group Order dockets did not print when using Print by Order Type. - Fixed an issue where the last category in the POS category list was not visible on mobile devices when Group Ordering was enabled. - Fixed an issue where newly created printers had no assigned order types in Register Printer Settings.
IMPROVED - Group Order dockets now display the selected order type (e.g., Dine-In, Takeaway, Delivery). - Group Orders now retain the selected Order Type for all orders in the group, eliminating the need to reselect it for each order.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Mar 16, 2025 - 23:36 EDT
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).