Restaurant O-Series: Accounting Integrations not loading

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Apr 13, 2025 - 23:47 EDT

Investigating

We have received reports that some customers are unable to access their accounting integrations (Xero, MYOB or Quickbooks).

Our teams are currently investigating.
Posted Apr 13, 2025 - 21:50 EDT
This incident affected: Lightspeed Restaurant (O-Series) (Accounting Integrations).