Issue with Cayan Manual Entry Payments

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 16:10 EDT

Monitoring

Cayan has reported that a potential fix has been implemented
Posted Apr 01, 2025 - 15:44 EDT

Investigating

We’ve identified an issue where merchants using Cayan as their payment processor in Google Chrome are not able to process manual payments. This issue seems to be specific to Google Chrome and Safari. As a temporary workaround, switch to another browser such as Firefox to make such payments.
Posted Apr 01, 2025 - 15:02 EDT
This incident affected: Lightspeed Retail (R-Series) (Integrated Payments).