Lightspeed Payments Hospitality: Payout Delays for some Merchants in Switzerland

Incident Report for Lightspeed - Status Page

Resolved

The third-party partner has resolved the issue. Payout scheduled on the 4th and 5th, both arrived on the 5th.
Posted Sep 05, 2025 - 05:20 EDT

Investigating

The September 4th payout has been delayed. All missing funds will be paid out tomorrow, Friday the 5th, by 11:00 AM CEST. We apologize for the inconvenience.
Posted Sep 04, 2025 - 09:02 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).