Degraded performance for Hospitality Lightspeed Payments in North America
Incident Report for Lightspeed - Status Page
Resolved
This morning's issue has been fully resolved.
Posted Nov 14, 2024 - 12:25 EST
Monitoring
We've identified and fixed an issue with our processing service for a subset of merchants based in North America.
Posted Nov 14, 2024 - 10:56 EST
This incident affected: Lightspeed Restaurant (L-Series) (Lightspeed Payments) and Lightspeed Restaurant (K-Series) (Lightspeed Payments).