Lightspeed Payments Bank Account Linking Issue

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Oct 08, 2025 - 16:03 EDT

Investigating

We are currently investigating an issue affecting merchants trying to connect a bank account to Lightspeed Payments via Plaid
Posted Oct 08, 2025 - 14:13 EDT
This incident affected: Lightspeed Restaurant (K-Series) (Lightspeed Payments).