We can confirm Payment processing in EU has fully recovered since 19:39 CEST. If you're still having issues, we recommend rebooting your payment terminals. We sincerely apologize for the inconvenience caused and thank you for your patience.
Posted Apr 21, 2025 - 14:37 EDT
Identified
We have identified the external issue and are in contact with our processing partner. We are seeing a recovery of Payments services starting on 19:35 CEST.
Posted Apr 21, 2025 - 13:46 EDT
Investigating
There is a known issue affecting Payments processing for a subset of our European based merchant. We’re currently investigating this issue and will provide an update as soon as possible.
Posted Apr 21, 2025 - 13:23 EDT
This incident affected: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), and Lightspeed Restaurant (K-Series) (Payments).