Lightspeed Payments Hospitality merchants may experience a degradation in payout reporting for the dates of September 4th and 5th 2025

Incident Report for Lightspeed - Status Page

Update

We are continuing to work on a fix for this issue.
Posted Sep 07, 2025 - 18:50 EDT

Identified

The issue has been identified and a fix is being worked on. The payout reporting for September 4th and 5th 2025 will be delayed.
Posted Sep 07, 2025 - 18:46 EDT
This incident affects: Lightspeed Restaurant (G-Series) (Lightspeed Payments), Lightspeed Restaurant (L-Series) (Lightspeed Payments), Lightspeed Restaurant (K-Series) (Lightspeed Payments), and Lightspeed Restaurant (O-Series) (Lightspeed Payments).