Images are not loading on the storefront and back office

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 17:45 EDT

Monitoring

We have implemented a fix and will continue to monitor the situation.
Posted Jun 11, 2025 - 17:44 EDT

Investigating

Images are either not loading or loading extremely slowly on both the storefront and the back office for C-Series. Clicking the Manage Online button is also affected and will return 503 Service Unavailable.
Posted Jun 11, 2025 - 17:15 EDT
This incident affected: Lightspeed eCom (C-Series) (Lightspeed eCom (North America & Australia)).