Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 22, 2025 - 01:00 EDT
Scheduled
We're excited to announce another update to your POS that will bring improved efficiency and stability.
Update Time: Tuesday, April 22 at 15:00 AEST Update Process: No need to interrupt your sales. Your POS will automatically update after 15:00 AEST.
NEW - All new Lightspeed Payments terminal pairings now default to cloud connection, improving reliability and enabling integrated payments over cellular networks.
IMPROVED - Increased the POS-side timeout for Lightspeed Payments from 60 to 120 seconds to prevent premature cancellations during slower transactions.
RESOLVED - Fixed an issue where the gift card settings page failed to load for some users. - Updated the Hey You settings link to open the correct portal after enabling the add-on.
IN CASE YOU MISSED IT Love Lightspeed? It's now even easier to share with your friends, and you get $1,000 for each referral! See the 'Refer us' tile on your Back Office dashboard for more details.
Posted Apr 15, 2025 - 01:10 EDT
This scheduled maintenance affected: Lightspeed Restaurant (O-Series) (POS, Back Office).