Degraded Performance - Services Page

Incident Report for Lightspeed - Status Page

Resolved

This incident has been resolved.
Posted Apr 01, 2025 - 10:34 EDT

Investigating

Users currently can't edit service or schedule in the services page. Our team is investigating this.
Posted Apr 01, 2025 - 10:32 EDT
This incident affected: Lightspeed Retail (X-Series) (Products, Reporting).